Website down

Resolved

The majority of issues causing our website outage has been resolved.
Posted Apr 22, 2025 - 19:58 EDT

Update

A fix has been implemented and we are currently monitoring our site for any issues. Media uploads across our site have been paused until we are able to justify this fix. See more info here:

https://mc-creativebuilding.net/community/threads/media-upload-feature-temporarily-paused.80/
Posted Mar 30, 2025 - 01:55 EDT

Update

It appears that our host has made some additional changes that caused another outage.
We are looking into this.
Posted Mar 29, 2025 - 23:32 EDT

Monitoring

The majority of our website is back but the backup restoration is still in progress.
Please remain patient as we monitor the status of our backup.

**Update 15:05/3:05 EDT**
- All of our website has been restored, but we have temporarily disabled file uploads on our server to allow us to fix a few things.
Posted Mar 29, 2025 - 14:39 EDT

Identified

We've found the issue and we are restoring a backup from about 1:30 P.M. Eastern Time from March 28th, 2025
Posted Mar 29, 2025 - 14:07 EDT

Investigating

A majority of our website's data has been deleted due to an issue likely with our host. We are actively working with them to resolve this issue.
Please rest assured that your data is safe.
Posted Mar 28, 2025 - 13:34 EDT
This incident affected: Website, CDN Server, Website SecureServer, Website Media Proxy, Forums Account Services, Forums Account API, and SQL Databases.