We are continuing to work on a fix for this issue.
Posted Apr 22, 2025 - 19:59 EDT
Identified
This issue ties in with our website being down because part of our services used within games requires our website to be active. We are working on a fix.
Posted Mar 30, 2025 - 14:39 EDT
This incident affects: Gaming Services (Online Gaming Services, DropNGo).